aboutsummaryrefslogtreecommitdiff
path: root/nix/default.nix
diff options
context:
space:
mode:
authorPeter Bex <peter@more-magic.net>2023-03-19 10:06:45 +0100
committerPeter Bex <peter@more-magic.net>2023-03-19 10:46:25 +0100
commit9d05c9ca73c2b501744d528475532ab728318bde (patch)
tree66290d3bf9974ab7cf418508cc0937b838fd0343 /nix/default.nix
downloadppq-9d05c9ca73c2b501744d528475532ab728318bde.tar.gz
Initial version of "ppq" - portable PostgreSQL
This allows running PostgreSQL locally without having to set up a system-wide service. It is portable in the sense that you can move the directory around, and you can run multiple instances side-by-side.
Diffstat (limited to 'nix/default.nix')
-rw-r--r--nix/default.nix15
1 files changed, 15 insertions, 0 deletions
diff --git a/nix/default.nix b/nix/default.nix
new file mode 100644
index 0000000..ba8291d
--- /dev/null
+++ b/nix/default.nix
@@ -0,0 +1,15 @@
+{
+ system ? builtins.currentSystem,
+ pkgs ? import ./pkgs.nix { inherit system; }
+}:
+let
+ lib = pkgs.lib;
+ shell = pkgs.mkShell {
+ name = "portable-postgresql";
+ buildInputs = with pkgs; [
+ ppq_postgresql
+ ];
+ };
+in {
+ inherit shell pkgs;
+}