aboutsummaryrefslogtreecommitdiff
path: root/nix/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nix/default.nix')
-rw-r--r--nix/default.nix15
1 files changed, 15 insertions, 0 deletions
diff --git a/nix/default.nix b/nix/default.nix
new file mode 100644
index 0000000..ba8291d
--- /dev/null
+++ b/nix/default.nix
@@ -0,0 +1,15 @@
+{
+ system ? builtins.currentSystem,
+ pkgs ? import ./pkgs.nix { inherit system; }
+}:
+let
+ lib = pkgs.lib;
+ shell = pkgs.mkShell {
+ name = "portable-postgresql";
+ buildInputs = with pkgs; [
+ ppq_postgresql
+ ];
+ };
+in {
+ inherit shell pkgs;
+}